Update Reference to Latest Version?

Oct 14, 2010 at 6:39 PM

I am loving NuPack! Had to run off and show several co-workers.  The first question they all asked was, "Will or does NuPack have a way to update the current references to the latest version?".  So I thought I would bring it up here.

Thanks,

Jay

 

Oct 14, 2010 at 6:44 PM
Let me be sure I understand what you are asking. You mean they have existing references and want NuPack, once they start using it, to be able to update those existing references?
____
Rob
"Be passionate in all you do"

http://devlicio.us/blogs/rob_reynolds
http://ferventcoder.com
http://twitter.com/ferventcoder

Oct 14, 2010 at 7:06 PM

Kind of.  I wouldn't expect it to be able to do that for reference not managed by NuPack but I would think once you have added a package reference it could let you know when new versions are available and give you the option to update.

Oct 14, 2010 at 7:25 PM
Oh ya man - fully planned for that. It might work now. :D
____
Rob
"Be passionate in all you do"

http://devlicio.us/blogs/rob_reynolds
http://ferventcoder.com
http://twitter.com/ferventcoder

Oct 14, 2010 at 7:29 PM

How would I find it it is already available?

Oct 14, 2010 at 7:37 PM

in the console, type "List-Package -Updates"

Oct 14, 2010 at 7:59 PM
Edited Oct 14, 2010 at 8:01 PM

Cool that gives you the list of packages and if there are updates available. 

PM> List-Package -Updates

Id                                         Version                                                             UpdateAvailable
--                                         -------                                                             ---------------
Antlr                                      3.1.1                                                                 False
Castle.Core                            1.1.0                                                                 True
Castle.DynamicProxy               2.1.0                                                                 True
Iesi.Collections                       1.0                                                                    False
log4net                                 1.2.1                                                                  False
NHibernate.Core                   2.1.2                                                                   False
NHibernate.Linq                    1.0                                                                     False

I did some digging and it looks like to update a package it would be.

PM> nup Castle.Core

or

PM> Update-Package Castle.Core

But fails because of the NHibernate dll has a dependency on this version. 

Does that sound right?

Oct 14, 2010 at 8:03 PM

Yes, that's expected.

Oct 14, 2010 at 8:10 PM
Edited Oct 14, 2010 at 8:10 PM

Awesome!

Thanks for the help. 

Consider me a NuPack Evangelist!!!!!

Working on a demo for internal developers where I work.

Thanks again.

Oct 14, 2010 at 8:13 PM

Glad that you like it. Don't forget to suggest new features and report issues in the Issue tracker. :)

Oct 14, 2010 at 10:24 PM

Jay, you've been quoted :)