Rename List-Package to Get-Package

Oct 2, 2010 at 1:07 AM

I just realized that the verb 'List' in List-Package is not one of the approved verbs. We need to rename it to Get-Package for CTP2. Agreed?

Oct 2, 2010 at 1:10 AM

I feel like we should either go Add/Get/Remove or Install/List/Uninstall. I personally like the latter, even if it isn't PowerShell-y. I thin install is a more intuitive verb for packaging software.

Coordinator
Oct 2, 2010 at 1:34 AM

I agree with Drew. Even now, I keep typing "Install-Package" because it's more intuitive to me. By the way, where is this so called "Approved Verb List" we keep mentioning. I'd like to see a reference. I don't think it's cool that we made this change in the first place while I was on vacation and didn't have a chance to object. :P

I need the chance to weigh in on anything that affects the user experience, or I'll get blamed as the so called "PM". ;)

Oct 2, 2010 at 2:08 AM

Here is the list of recommended verbs: http://msdn.microsoft.com/en-us/library/ms714428(VS.85).aspx

I also like Install/List/Uninstall. But at the same time I also think conforming to PS convention is a good thing to do.


From: haacked [notifications@codeplex.com]
Sent: Friday, October 01, 2010 6:34 PM
To: Luan Nguyen
Subject: Re: Rename List-Package to Get-Package [nupack:229374]

From: haacked

I agree with Drew. Even now, I keep typing "Install-Package" because it's more intuitive to me. By the way, where is this so called "Approved Verb List" we keep mentioning. I'd like to see a reference. I don't think it's cool that we made this change in the first place while I was on vacation and didn't have a chance to object. :P

I need the chance to weigh in on anything that affects the user experience, or I'll get blamed as the so called "PM". ;)

Editor
Oct 2, 2010 at 2:13 AM
Easily solved. Use the approved verbs list for the actuals, and add alias foe your preferred ones. Build it into the initial script.
>
Coordinator
Oct 2, 2010 at 3:14 AM
I like that idea. Any reason not to?
>
Oct 2, 2010 at 3:26 AM

I think that is a go.

Oct 2, 2010 at 4:21 AM
+1 - everybody's happy.
____
Rob
"Be passionate in all you do"

http://devlicio.us/blogs/rob_reynolds
http://ferventcoder.com
http://twitter.com/ferventcoder

Coordinator
Oct 2, 2010 at 4:44 AM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Coordinator
Oct 2, 2010 at 4:46 AM

Opened issue 155: http://nupack.codeplex.com/workitem/155

Oct 2, 2010 at 3:43 PM

You know what, Install and Uninstall are actually approved verbs.

http://msdn.microsoft.com/en-us/library/system.management.automation.verbslifecycle_fields(VS.85).aspx

Coordinator
Oct 2, 2010 at 6:12 PM
Booyah! Then I say no aliases for those two and we rename them back.

List is still not approved so I think we can alias just that one.
Editor
Oct 2, 2010 at 6:28 PM
We'll need aliases for the alternates, whichever we choose.
>
Coordinator
Oct 2, 2010 at 6:34 PM
Why? The reason we renamed these in the first place was due to a mistaken belief that Add-Package was the approved conventional name rather than Install-Package. It turns out, that's not the case and we never needed to rename it in the first place. And I don't think we should have renamed it. So my preference is not not have aliases for Install-Package and Uninstall-Package.

I do think we should have an alias for Get-Package though. That I agree with.
Editor
Oct 2, 2010 at 6:53 PM
Install must be new, because I'm not seeing it listed here: http://msdn.microsoft.com/en-us/library/system.management.automation.verbscommon_members(VS.85).aspx

I'm saying, have both because just because you/we think install is intuitive, doesn't mean add isn't more so. Pick one an alias the other and everyone wins. Aliases are easy and harmless and beneficial.
>
Coordinator
Oct 2, 2010 at 7:06 PM

We can let users add their own aliases. I think we should try to avoid having two ways to do the same thing unless we have a very good reason not to. It keeps things consistent and avoids confusion. For example, if in your screencast you show Add-Package and I show Install-Package, that creates confusion.

Looking at the descriptions of these verbs according to the PS docs:

  • Add - Adds a resource to a container, or attaches an item to another item. For example, the Add-Content cmdlet adds content to a file. This verb is paired with Remove.
  • Install - Specifies an action that places a resource in a location, and optionally initializes it.

I think Install perfectly describes what we're doing. Let's look at it this way, if the original list we looked at had the verbs "Install" and "Uninstall", we'd never be having this discussion. We wouldn't add more aliases. So let's not do that. If we hear customer feedback that people really want to use Add- and Remove-, we can consider adding them in as aliases. But I'd rather just remove them now and see what the feedback is. Thanks!

Oct 2, 2010 at 7:10 PM

Using install and uninstall, I like the short aliases. nip and nup.  for install and uninstall respectively.

Editor
Oct 2, 2010 at 7:24 PM
LOL at nip and nup.
>
Oct 2, 2010 at 7:43 PM
yeah.. nrp and nap just do not do it for me.
Oct 2, 2010 at 8:53 PM

Nip and nup are very close to nip and tuck. Lol!

____
Rob
"Be passionate in all you do"

http://devlicio.us/blogs/rob_reynolds
http://ferventcoder.com
http://twitter.com/ferventcoder

Oct 2, 2010 at 9:13 PM

That's a plan.  We never really liked add/remove, but had done it for PS compliance.  If that was based on incorrect data (let's be real sure!), there is no reason stay with that less clear naming.

Oct 2, 2010 at 9:50 PM
erichexter wrote:

Using install and uninstall, I like the short aliases. nip and nup.  for install and uninstall respectively.

Note that 'nup' is already used for Update-Package. IMO, Uninstall-Package is more often used than Update-Package, so maybe we should give 'nup' to it.