Note that we had a previous
discussion on this with some good content. My first reaction reading the proposal (I missed the meeting where this was discussed :) ) is that it seems a bit over-engineered compared to the naming convention approach.
What if declaring a beta package was as simple as naming it something like "SomePackage.beta" (or alpha, or some other known tokens), with no changes to the nuspec format nor the feed format?
Then we could build some smart in the client such that doing 'install-package -beta SomePackage' really means 'install-package SomePackage.beta', so the client experience would be similar to what your proposal describes.
And if we don't want to show pre-release packages in the dialog, it would be a matter of filtering out those that end with .alpha, .beta, ...
There are probably a few tricky issues to solve, but on the surface it seems solvable, and a much smaller scope feature than adding new flags in the nuspec and feed.